반응형
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞은 사람 | 정답 비율 |
---|---|---|---|---|---|
1 초 | 128 MB | 30795 | 15437 | 11095 | 49.215% |
문제
정사각형으로 이루어져 있는 섬과 바다 지도가 주어진다. 섬의 개수를 세는 프로그램을 작성하시오.
한 정사각형과 가로, 세로 또는 대각선으로 연결되어 있는 사각형은 걸어갈 수 있는 사각형이다.
두 정사각형이 같은 섬에 있으려면, 한 정사각형에서 다른 정사각형으로 걸어서 갈 수 있는 경로가 있어야 한다. 지도는 바다로 둘러싸여 있으며, 지도 밖으로 나갈 수 없다.
입력
입력은 여러 개의 테스트 케이스로 이루어져 있다. 각 테스트 케이스의 첫째 줄에는 지도의 너비 w와 높이 h가 주어진다. w와 h는 50보다 작거나 같은 양의 정수이다.
둘째 줄부터 h개 줄에는 지도가 주어진다. 1은 땅, 0은 바다이다.
입력의 마지막 줄에는 0이 두 개 주어진다.
출력
각 테스트 케이스에 대해서, 섬의 개수를 출력한다.
예제 입력 1
1 1
0
2 2
0 1
1 0
3 2
1 1 1
1 1 1
5 4
1 0 1 0 0
1 0 0 0 0
1 0 1 0 1
1 0 0 1 0
5 4
1 1 1 0 1
1 0 1 0 1
1 0 1 0 1
1 0 1 1 1
5 5
1 0 1 0 1
0 0 0 0 0
1 0 1 0 1
0 0 0 0 0
1 0 1 0 1
0 0
예제 출력 1
0
1
1
3
1
9
코드
import java.io.*;
import java.util.*;
public class p4963 {
static BufferedReader br;
static StringTokenizer st;
static String input;
static int w, h, sum, map[][];
static boolean visit[][];
static int[] dx = {0, 0, 1, -1, 1, 1, -1, -1};
static int[] dy = {1, -1, 0, 0, 1, -1, 1, -1};
public static void main(String[] args) throws IOException {
br = new BufferedReader(new InputStreamReader(System.in));
while (true) {
st = new StringTokenizer(br.readLine());
w = Integer.parseInt(st.nextToken());
h = Integer.parseInt(st.nextToken());
if (w == 0 && h == 0) break;
map = new int[h + 1][w + 1];
visit = new boolean[h + 1][w + 1];
for (int i = 1; i <= h; i++) {
st = new StringTokenizer(br.readLine());
for (int j = 1; j <= w; j++) {
map[i][j] = Integer.parseInt(st.nextToken());
}
}
sum = 0;
for (int i = 1; i <= h; i++) {
for (int j = 1; j <= w; j++) {
if (map[i][j] == 1 && !visit[i][j]) {
bfs(new Point(i, j));
sum++;
}
}
}
System.out.println(sum);
}
}
static void bfs(Point start) {
Queue<Point> q = new LinkedList<>();
q.add(start);
while (!q.isEmpty()) {
Point cur = q.poll();
int a = cur.x;
int b = cur.y;
visit[a][b] = true;
for (int i = 0; i < 8; i++) {
int nx = a + dx[i];
int ny = b + dy[i];
if (nx <= 0 || ny <= 0 || nx >= h + 1 || ny >= w + 1) continue;
if (map[nx][ny] == 0 || visit[nx][ny]) continue;
q.add(new Point(nx, ny));
visit[nx][ny] = true;
}
}
}
static class Point {
int x, y;
Point(int x, int y) {
this.x = x;
this.y = y;
}
}
}
반응형
'알고리즘 > [ Baekjoon ]' 카테고리의 다른 글
[ BOJ ][JAVA][5052] 전화번호 목록 (0) | 2021.04.25 |
---|---|
[ BOJ ][JAVA][5014] 스타트링크 (0) | 2021.04.25 |
[ BOJ ][JAVA][4949] 균형잡힌 세상 (0) | 2021.04.25 |
[ BOJ ][JAVA][4659] 비밀번호 발음하기 (0) | 2021.04.25 |
[ BOJ ][JAVA][4568] LRU Caching (0) | 2021.04.25 |