알고리즘/[ Baekjoon ]

[ BOJ ][JAVA][1167] 트리의 지름

kim.svadoz 2021. 4. 17. 22:15
반응형

https://www.acmicpc.net/problem/1167

시간 제한 메모리 제한 제출 정답 맞은 사람 정답 비율
2 초 256 MB 16697 6017 4382 35.067%

문제

트리의 지름이란, 트리에서 임의의 두 점 사이의 거리 중 가장 긴 것을 말한다. 트리의 지름을 구하는 프로그램을 작성하시오.

입력

트리가 입력으로 주어진다. 먼저 첫 번째 줄에서는 트리의 정점의 개수 V가 주어지고 (2 ≤ V ≤ 100,000)둘째 줄부터 V개의 줄에 걸쳐 간선의 정보가 다음과 같이 주어진다. 정점 번호는 1부터 V까지 매겨져 있다.

먼저 정점 번호가 주어지고, 이어서 연결된 간선의 정보를 의미하는 정수가 두 개씩 주어지는데, 하나는 정점번호, 다른 하나는 그 정점까지의 거리이다. 예를 들어 네 번째 줄의 경우 정점 3은 정점 1과 거리가 2인 간선으로 연결되어 있고, 정점 4와는 거리가 3인 간선으로 연결되어 있는 것을 보여준다. 각 줄의 마지막에는 -1이 입력으로 주어진다. 주어지는 거리는 모두 10,000 이하의 자연수이다.

출력

첫째 줄에 트리의 지름을 출력한다.

예제 입력 1

5
1 3 2 -1
2 4 4 -1
3 1 2 4 3 -1
4 2 4 3 3 5 6 -1
5 4 6 -1

예제 출력 1

11

코드

import java.io.*;
import java.util.*;

public class p1167 {
    static BufferedReader br;
    static StringTokenizer st;
    static int V;
    static List<Edge>[] list;
    public static void main(String[] args) throws IOException {
        br = new BufferedReader(new InputStreamReader(System.in));
        V = Integer.parseInt(br.readLine());

        list = new ArrayList[V + 1];
        int[] dust = new int[V + 1];

        for (int i = 1; i <= V; i++) {
            list[i] = new ArrayList<>();
        }

        for (int i = 1; i <= V; i++) {
            st = new StringTokenizer(br.readLine());
            int u = Integer.parseInt(st.nextToken());

            int v = -1;
            while ((v = Integer.parseInt(st.nextToken())) != -1) {
                int dist = Integer.parseInt(st.nextToken());
                list[u].add(new Edge(v, dist));
            }
        }
        dust = bfs(list, 1);

        int start = 0;
        for (int i = 1; i < dust.length; i++) {
            if (dust[start] < dust[i]) {
                start = i;
            }
        }

        dust = bfs(list, start);

        int max = start;
        for (int i = 1; i < dust.length; i++) {
            if (dust[max] < dust[i]) {
                max = i;
            }
        }

        System.out.println(dust[max]);
    }

    static int[] bfs(List<Edge>[] list, int start) {
        boolean[] visit = new boolean[V + 1];
        int[] dust = new int[V + 1];

        Queue<Integer> q = new LinkedList<>();
        q.add(start);
        visit[start] = true;

        while (!q.isEmpty()) {
            int cur = q.poll();
            visit[cur] = true;

            for(Edge e : list[cur]) {
                int y = e.y;
                int cost = e.cost;
                if (!visit[y]) {
                    q.add(y);
                    dust[y] = dust[cur] + cost;
                }
            }
        }

        return dust;
    }

    static class Edge {
        int y, cost;
        public Edge(int y, int cost) {
            this.y = y;
            this.cost = cost;
        }
    }
}

핵심은, BFS를 두번 돌아 지름을 구하는 것.

반응형